I'm having problem with Assessment Engine. How should I fix?

Depending on the browser and operating system at times the assessment system may not work. We are fixing a few things to make the assessment engine compatible with all the browsers and operating systems. In meanwhile, please follow the below steps to make the most out of the assessment engine.

  1. If you are getting a 404 error on the assessment page, then please run below command on your webconsole and then reload the assessment page.

rsync -avz --ignore-existing /cxldata/cloudxlab_jupyter_notebooks/ /home/$USER/cloudxlab_jupyter_notebooks/

  1. If you think your logic is correct and still system is not accepting the answer then please follow below steps on the right-hand side(Where Jupyter notebook appears)
  • Make sure you are working on the Jupyter notebook appearing on the right-hand side of the assessment page. The assessment engine can evaluate your answer only if it is submitted in the notebook which appears on the right-hand side of the assessment page.

  • Close all other Jupyter notebook tabs in your browser

  • Click on “File” and then “Save and Checkpoint”. Wait for the checkpoint to be created

  • Click on “Control panel”

  • Click on “Stop My Server”. Wait for the server to stop

  • Click on “Start My Server” and wait for the server to start.

  • Once the server is started, you will see something like the below image interface.

  • Now reload the assessment page, execute the code again in the notebook and resubmit the answer

  • Here is the screencast covering the above steps of point 2.
1 Like

Assessment not able to catch my jupyter answers.

Even after following the above steps?

Hi ,

Even after following the steps listed above I am facing similar error .

even after following all steps .

Thanks,
Shruthi Gopinath Rao

first and second final

Hi @shruti_rao

What error are you getting? Could you please paste the screenshot? Lets open a sep discussion thread for this

I am not able to submit my answer. When I click submit it shows checking please wait and then nothing happens. Please help

@varnika_vasundhrae Can you try re-connecting with the Lab and re-submit?

@Ashwani_Gupta1 I did. Still the same problem

i am logged in web console but when i try to submit answer it says that i am not logged in .

Hi Team,
I am not able to submit answer. i think my code is correct but then also its not accepting. Can you please help on that? below is my code:-

height = 20
width = 80
area_of_rectangle = height * width
print(area_of_rectangle)
type(area_of_rectangle)

Expected output should be = int
my output = int

But its not accepting, i tried restarting my lab server , and logout and again login to lab and refresh the page, but still its not working.

Please help on this .

** here is the question **-----> for you reference
Use the Jupyter notebook on the right-hand side. Press Shift + Enter to run code in individual cells.

In the previous exercise, find out the type of area_of_rectangle variable using type() function
The type of area_of_rectangle variable is

Hi Krishna,

We have to fill the answer i.e. int in the box provided and then submit. If its still not working, skip it for now and continue. You can try again later.

The error will be resolved asap by the Cloudxlab Team.

Regards.

Hi team,
I am facing an issue in submitting my answer. I am not able to continue with my course. I am facing this issue for a long time now. I have tried everything. I tried to reach you guys a couple of times but no one responded.
Please help me out.

Hi Varnika,

Please drop a mail with the screenshot of the error to reachus@cloudxlab.com

Regards.


I am having problem while submitting the answer in the assessment engine for the Email project . It always shows that cannot connect to lab, check ur internet connection. I have a working network connection . as u can see on the taskbar in the ss . Earlier I didn’t have such problems while submitting the answer .
Help me .

1 Like

I did. No one has replied to the mail yet.

Thanks Ankur, it helped!!

1 Like

Hi @varnika_vasundhrae Are you still facing the issue?

Yes. Deadline of my course is near. I need help

Please respond. What happened? No one is helping my situation.