Cannot connect to server in Jupyter Notebook

I have completed coding the Topic 16 project. However, since it features a number of models, when running the notebook, it starts running fine but after a while it says “Cannot connect to Kernel”. My internet connection is working fine, I tried reconnecting to the Kernel from within the Jupyter notebook, but it didn’t work. I tried the same a number of time but it failed everytime and gave the same error. I even tried to run one line at a time, same error.

So, I am unable to test my code. Is there a way around it? Am I doing something wrong?

Just so that you know, I cannot view the default Jupyter notebook on playground anymore. I tried the following command:

rsync -avz --ignore-existing /cxldata/cloudxlab_jupyter_notebooks/ /home/$USER/cloudxlab_jupyter_notebooks/

Still no go.

Can you please share the screenshot?

Here are the screenshots. The playground I think is working fine. It was not showing the relevant workbook since we are supposed to create a separate workbook for topic 16. However, the other issue of kernel not connecting is still there. I tried the code in my personal laptop, it took a bit of time but it worked fine.

Hi, Rajtilak.
Kindly refresh the page or restart your server again.

Please refer to this article for more information.

All the best!

Did you try reloading the page?

@satyajit_das The issue with the missing playground notebook has been resolved. Thank you!

@abhinav I have tried the following for the kernel issue:

  1. Reloading the page
  2. Trying a different browser
  3. Ran one line of code at a time
  4. Reconnecting the kernel
  5. Restarting the kernel
    Still no go.

Hi @abhinav, any updates on this issue?

At times when the server load is high the notebook may not connect. Are you still not able to connect to it?

Jupyter is not working. It is showing * mark from long time. i have already restart multiple times. please resolve it asap because i am not able to submit my assignment.

Please need response on it.

Hi @abhinav, I am still facing the same issue. I tried it today too, and after testing a couple of models (irrespective of whether I ran all at once or I ran one at a time), it stopped saying it was unable to connect to the kernel.

I cannot test my models because of this issue. Please suggest a way forward.

Hi @Rajtilak,

As discussed over the call, please do not use XGBoost on the lab as it will consume all the resources and the notebook will be killed by bots


Yes, thank you for taking the time to call me up to discuss the issue. Also, as discussed, I would prepare the project on Google Colab or my local laptop and share the notebook with you.

Project completed and submitted. Thank you for all your support @abhinav.