504 Gateway Time-out 504 Gateway Time-out nginx/1.12.2

Getting very frequently " 504 Gateway Time-out 504 Gateway Time-out nginx/1.12.2

when accessing “Hue”.

Hardly able to access the lab for 60 mins a day. Tried at different times and queries I am attempting to execute are very basic ones (select count(*), etc…,)

Appreciate your help in resolving this

Hi,

Is this occurring while accessing Hive or HDFS or HBase?

Since we recently moved from AWS to GCP, there might be some teething issues that we are working on.

facing same problem in hive,please guide me

1 Like

I have been facing this same issue in hive since yesterday

This happens when the query is taking too much time. Could you check if the query is taking too much time?

The query is hanging and taking longer than expected. That is what it says

Is it possible to share the query?

Have you tried running it from hive console? You can log in into the web console and type “hive” (without quotes).

It worked on console earlier.

no sir ,tried in hue only

I am also facing the same error while executing the hive query from both console and Hue.
I ran the query
‘SELECT count(id) FROM tweets_raw;’ under ‘Hive - Project’ Chapter.

getting the error 504 Gateway Time-out 504 Gateway Time-out nginx/1.12.2 on Hue continuously on screen.
Below are the logs from the console. it got hanged here in console.

Hadoop job information for Stage-1: number of mappers: 29; number of reducers: 1
2019-09-01 14:32:40,883 Stage-1 map = 0%, reduce = 0%
2019-09-01 14:32:49,738 Stage-1 map = 10%, reduce = 0%, Cumulative CPU 12.61 sec
2019-09-01 14:32:50,851 Stage-1 map = 17%, reduce = 0%, Cumulative CPU 33.22 sec
2019-09-01 14:32:52,995 Stage-1 map = 21%, reduce = 0%, Cumulative CPU 39.13 sec
2019-09-01 14:32:54,098 Stage-1 map = 25%, reduce = 0%, Cumulative CPU 46.76 sec
2019-09-01 14:32:55,189 Stage-1 map = 31%, reduce = 0%, Cumulative CPU 63.06 sec
2019-09-01 14:32:57,358 Stage-1 map = 34%, reduce = 0%, Cumulative CPU 68.18 sec
2019-09-01 14:32:59,446 Stage-1 map = 48%, reduce = 0%, Cumulative CPU 94.0 sec
2019-09-01 14:33:00,483 Stage-1 map = 57%, reduce = 0%, Cumulative CPU 106.21 sec
2019-09-01 14:33:01,521 Stage-1 map = 69%, reduce = 0%, Cumulative CPU 134.29 sec
2019-09-01 14:33:29,598 Stage-1 map = 76%, reduce = 0%, Cumulative CPU 145.17 sec
2019-09-01 14:34:29,692 Stage-1 map = 76%, reduce = 0%, Cumulative CPU 145.17 sec
2019-09-01 14:35:29,705 Stage-1 map = 76%, reduce = 0%, Cumulative CPU 145.17 sec
2019-09-01 14:36:29,744 Stage-1 map = 76%, reduce = 0%, Cumulative CPU 145.17 sec

Kindly help to resolve this issue ASAP.

Actually, the hue is behind the NginX gateway. When the query takes a long time, nginx stops it.

So, could try a long running query from the console?

Hello Sandeep,
Even I’m facing the Gateway Time-out issue when i try to access the Hive editor in hue. Even a simple “select * from table limit 5;” fails to execute.
I can run the queries using the console but i would also like to access the editor in hue.

Can you please help me get this issue resolved?
Thanks.

Facing a similar issue. I had some problem in executing a create table cmd. So, I created the table in web console. after this, I want to use hue editor to check the table. The refresh button doesn’t get the updated table. It says ERROR IN LOADING DATABASE.

THis is happening since a 3 days.

I have tried to cleanup the Hue. Please let me know if you are observing this. If so, we will try to upgrade/downgrade or upscale the Hue machine.

Hi Sandeep,

I see most of the time nginx error for hue, could not load normal databases also;

hi,

I am getting this error too often, can you please help.

Hello,

I am still facing this error while accessing my db in Hive editor.

This issue persists from last 1 week and I am not able to complete my course which is time bound.

Kindly help me in this.

Please use hive from console.