Hue Oozie workflow submit stopped at 50% progress


#1

Hello,
Hue Oozie workflow, sqoop action, shell script action and Hive script action all three are surprisingly…halted at 50% progress…even after waiting for several minutes…I have tried it multiple times and all the times…it is halting at 50% progress…


#2

Hi BV_Raju,

Could you please specify the detailed steps which you have tried so that I will try to reproduce the issue & help you with this.


#3

Step1. logged in to cloudxlab web console

Step2. created a shell script file - nano raju_oozie_testing.sh
#!/bin/bash
echo “Hello BVRaju, how is cloudxlab?”

Step3. tested whether the script is working file
$ /bin/bash raju_oozie_testing.sh

got the expected output

Step4. Copied the above from the local file system to my HDFS home directory

successful

Step5. Verified the copying via HUE

successful

Step6. In HUE, opened workflow editor, dragged the shell script action and dropped it in the required area

selected the shell script file from the HDFS location
	click "Add"

click "Files+" , selected the same shell script file from the HDFS location

Step7. Saved the workflow

Step8. Submitted the workflow

But surprisingly it got struct at 50% progress and no progress even after several minutes (like 15 minutes)

Note: For all the three lessions in this topic, same problem, struct at 50% progress