Command is correct and the required result is obtained but not allowing me to submit the answer

I am stuck at Question 40 of Linux Basics. Details of the Question is as below:
Permission: Assignment - Only Group Members can read

Ignore the below instructions if you have already created myemptyfile file in the previous question

  1. Create a new file called myemptyfile. You can use:

                    touch myemptyfile
  2. Check its permissions using:

                   ls -l myemptyfile

Using chmod , give permissions to myemptyfile such that the owner of a file should be able to read and modify, members of groups can only read, others can read or modify.

Actually as per the above mentioned deatils of the problem, I need to give permissions to myemptyfile such that the owner of a file should be able to read and modify, members of groups can only read, others can’t read or modify. using chmod command. I need not to create a new file myemptyfile using touch command as already created.

I have run following commands:
i) chmod u-x,g-x,o-x myemptyfile
to remove the execute option from owner, group and others, as owner should have permission to read and modify only, whereas already it was having read write execute permissions.
ii) Secondlly I run command,
chmod g+r,o+rw myemptyfile
to add read permission to group as it was not having the read permissions, and added read and write permission to others as they were not having the read write permissions.
iii) After this when I checked with command
ls -l myemptyfile
it showed the output results as required, i.e,

[radheshyamkori4902@cxln4 ~]$ ls -l myemptyfile
-rw-r–rw- 1 radheshyamkori4902 radheshyamkori4902 0 May 11 23:29 myemptyfile

i.e. i) owner have only read and modify permissions
ii) group have only read permissions
iii) others have read and modify permissions
I clicked on the submit button after this but it was not accepting the answer displaying Error Message.

I deleted the file myemptyfile and created a new one again, and given permissions accordingly but still it is not accpeting the answer. I checked the Hint, which deducted 10XP and then I finally checked the answer for cost of 50XP. Just to check wheter It is accepting the given answer, I copied the command and pasted it in the webconsole, the command ran successfully and the output was same as which I got earlier.
Then I tried to submit the answer, but again it showed error on the page and not allowing to submit it as not accepting the answer. screenshot is attached with this email

Please reply what can be done in this case as its not allowing me to complete this Question 40 of linux basics.

Thanks & Regards,


The question asks to give permission so that others should not be able to read or modify. Could you please give permissions accordingly. Also please feel free to take inspiration from hint and see answer

Hi Abhinav,
Thanks for your reply. Sorry it was my mistake, I didn’t read and understand the problem completely, as I emphasized more on the
"modify, members of groups can only read,
due to which I missed the "can’t " in below pharse
"others can’t read or modify."

Thanks, for your reply, which made me to relook the problem and find the error I have made.

I have run the correct command and now I am able to submit the Problem no 40 of Linux Basics successfully.

Thanks & Regards,